Intermittent Access

Incident Report for Envisia Learning

Resolved

This incident has been resolved.
Posted 2 months ago. Feb 24, 2025 - 16:32 UTC

Investigating

Hi there,

We are currently investigating an issue with our IT provider, you may experience some intermittent downtime while we look into this. Please reach out to clientservices@envisialearning.com if you need further assistance.

Kind regards,
Envisia Learning
Posted 2 months ago. Feb 24, 2025 - 15:32 UTC
This incident affected: CustomView2.